2020. 5. 17. 00:50ㆍ네트워크/라우터
[RIP Version 2]
RIP version 1과 RIP version 2의 차이점은 다음과 같다.
RIP version 2는 멀티캐스트 주소 224.0.0.9를 사용한다.
RIP version 2는 auto-summary를 중지 시킬 수가 있다.(classless 방식)
RIP version 2는 클래스리스를 지원하기 때문에 VLSM 방식을 사용할 수가 있다.
RIP version 2는 수동 서머리를 하여 라우팅 테이블을 줄일 수가 있다.
RIP version 2는 인증을 사용하여 보다 강화된 네트워크를 구성할 수가 있다.
네트워크 관리자가 직접 ip를 축약해서 정보를 보내주는 것을 수동 서머리라고 한다.
[R1]
conf t
int loopback 0
ip add 172.16.1.254 255.255.255.0
int loopback 1
ip add 172.16.2.254 255.255.255.0
int loopback 2
ip add 172.16.3.254 255.255.255.0
int loopback 3
ip add 172.16.4.254 255.255.255.0
int loopback 4
ip add 172.16.5.254 255.255.255.0
int loopback 5
ip add 172.16.6.254 255.255.255.0
int loopback 6
ip add 172.16.7.254 255.255.255.0
int s2/0
ip add 192.168.12.1 255.255.255.252
ip summary-address rip 172.16.0.0 255.255.248.0
no shutdown
router rip
version 2
no auto-summary
network 172.16.0.0
network 192.168.12.0
end
copy r s
[R2]
conf t
int s2/0
ip add 192.168.12.2 255.255.255.252
no shutdown
int s2/1
ip add 192.168.23.2 255.255.255.252
no shutdown
exit
int f0/0
ip add 10.1.2.254 255.255.255.0
no shutdown
exit
router rip
version 2
no auto-summary
network 192.168.12.0
network 192.168.23.0
network 10.1.2.0
end
copy r s
[R3]
conf t
int s2/1
ip add 192.168.23.3 255.255.252.0
no shutdown
exit
int f0/0
ip add 192.168.3.254 255.255.255.0
no shutdown
exit
router rip
version 2
no auto-summary
network 192.168.3.0
network 192.168.23.0
end
copy r s
RIPv2 인증
R1(config)# key chain [key_name]
R1(config-keychain)# key [key_number]
R1(config-keychain-key)# [key-string password]
R1(config-keychain-key)# interface [serial 2/0]
R1(config-if)# ip rip authentication [key-chain key_name]
R1(config-if)# ip rip authentication mode [md5 | text
R1(config)# key chain master
R1(config-keychain)# key 5
R1(config-keychain-key)# key-string cisco
R1(cofnig-keychain-key)# interface serial 2/0
R1(config-if)# ip rip authentication key-chain master
R1(cofnig-if)# ip rip authentication mode md5
R2(config)# key chain client
R2(config-keychain)# key 5
R2(config-keychain-key)# key-string cisco
R2(cofnig-keychain-key)# interface serial 2/0
R2(config-if)# ip rip authentication key-chain client
R2(cofnig-if)# ip rip authentication mode md5
수동 서머리와 더불어 rip v2에서 사용할수 있는 인증기능을 r1과 r2사이에 설정하였다.
RIP v1과 v2가 함께하는 랩
[R1]
conf t
int f0/0
ip add 172.16.123.1 255.255.255.0
ip rip send version 1
ip rip receive version 1
no shutdown
exit
router rip
network 172.16.0.0
end
copy r s
[R2]
conf t
int f1/0
ip add 172.16.123.2 255.255.255.0
ip rip send version 2
ip rip receive version 2
no shutdown
exit
router rip
network 172.16.0.0
end
copy r s
[R3]
conf t
int f1/1
ip add 172.16.123.3 255.255.255.0
ip rip send version 2
ip rip receive version 2
no shutdown
exit
router rip
network 172.16.0.0
end
copy r s
[R4]
conf t
int f0/0
ip add 172.16.123.4 255.255.255.0
no shutdown
exit
conf t
int s2/0
ip add 172.16.45.4 255.255.255.0
ip rip send version 1
no shutdown
exit
router rip
network 172.16.0.0
end
copy r s
[R5]
conf t
int s2/0
ip add 172.16.45.5 255.255.255.0
ip rip send version 2
no shutdown
exit
router rip
network 172.16.0.0
end
copy r s
이렇게 오늘로 RIP 방식 라우팅 공부가 끝이 났다.
*RIP 요약
- RIPv1은 브로트캐스트를 한다. (UDP 520번)
- RIPv1은 클래스풀방식이다.(자동축약을 한다.)
- RIPv1은 홉카운트를 사용한다(15홉)
- RIP은 30초 간격으로 업데이트한다.
- RIPv2은 224.0.0.9 멀티캐스트를 사용한다.
- RIPv2은 클래스리스를 지원한다.(no auto-summary를 지원한다)
- VLSM 지원
- 인증방식 지원
- RIP은 인접한 라우터가 보내준 정보를 그대로 믿기 때문에 안정적이지 않다.
- 컨버젼스타임이 길기 때문에 트래픽을 유발시킨다.
- 회선속도나 대역폭을 전혀 고려하지 않는다.
- 디스턴스벡터 라우팅 프로토콜이기 때문에 스플릿 호라이즌을 해결해야 한다.
그리고 오늘은 EIGRP 맛보기를 하였다.
EIGRP는 Cisco에서 IGRP의 기능과 성능을 개선한 routing protocol이다.
시스코 전용(Cisco Proprietary) Routing Protocol이다.
Hybrid Protocol이다.: Link State와 Distance Vector Routing Protocols의 장점을
결합했다. Advanced Distance Vector Routing Protocol이다.
Rapid Convergence : Rapid Convergence를 위하여 DUAL(Diffusing Update
Algorithm)을 사용한다.
Bandwidth 를 적게 사용한다.
주기적인 업데이트를 하지 않는다.
Destination에 대한 Path나 Metric에 변화가 있을 때만(Incremental updates)
즉시 Partial Update를 한다.
또한 변화된 Link에 대한 Routing Information Update를 한다.
Routing Information이 필요한 라우터에만 Update를 한다. (Multicast Update)
Topology Database에서 최적의 Path를 찾아 내므로 100% Loop Free Routing
Protocol이다.
Configuration이 쉽다.
VLSM과 Discontiguous Network을 지원한다.
Multiple Network Layer Support : IP Routing외에도 IPX, AppleTalk Routing을
지원한다.
IGRP와 호환성이 있다.
대충 이정도의 특징을 가지고 있다.
[R1]
conf t
int f0/0
ip add 172.16.1.1 255.255.255.0
no shutdown
int s2/0
ip add 10.1.1.1 255.255.255.0
no shutdown
router eigrp 100
network 172.16.0.0
network 10.0.0.0
end
copy r s
[R2]
conf t
int f0/0
ip add 192.168.100.1 255.255.255.0
no shutdown
int s2/0
ip add 10.1.1.2 255.255.255.0
no shutdown
int s2/1
ip add 10.2.2.2 255.255.255.0
no shutdown
router eigrp 100
network 10.0.0.0
network 192.168.100.0
end
copy r s
[R3]
conf t
int s2/1
ip add 10.2.2.3 255.255.255.0
no shutdown
int f0/0
ip add 192.168.1.1 255.255.255.0
no shutdown
router eigrp 100
network 192.168.1.0
network 10.0.0.0
end
copy r s
[R4]
conf t
int f0/0
ip add 172.16.1.254 255.255.255.0
no shutdown
router eigrp 100
network 172.16.1.0
end
copy r s
[R5]
conf t
int f0/0
ip add 192.168.100.254 255.255.255.0
no shutdown
router eigrp 100
network 192.168.100.0
end
copy r s
[R6]
conf t
int f0/0
ip add 192.168.1.254 255.255.255.0
no shutdown
router eigrp 100
network 192.168.1.0
end
copy r s
RIP 때와 크게 다른점이 없어보이지만 router rip 과는 달리 router eigrp 100. 여기서 뒤에 숫자가 붙는다.
이 숫자를 autonomous-system, AS 넘버라고 하며 이 숫자가 같은 eigrp 끼리만 통신할 수 있다.
'네트워크 > 라우터' 카테고리의 다른 글
클라우드-02 (0) | 2020.05.17 |
---|---|
RIP-STATIC 재분배-02 (0) | 2020.05.17 |
EIGRP-02 (0) | 2020.05.17 |
EIGRP (0) | 2020.05.17 |
RIP Version 2 (0) | 2020.05.17 |